Find My iPhone: Native iPhone and iPad Security Location App

find my iphoneFind My iPhone is free for anyone with an iPhone 4, iPad, or 4th generation iPod touch (iOS 4.2 or later required).* Just sign in with your Apple ID on your qualifying device and turn on Find My iPhone to allow you to locate it. Then use the same Apple ID to turn on Find My iPhone on your other iOS 4.2 (or later) devices including iPhone 3G, 3GS, or iPod touch (2nd generation or later). Find My iPhone is also included with a MobileMe subscription.

If you lose your iPhone, iPad, or iPod touch while on the go, simply install the Find My iPhone app on another iOS device, launch it, and sign in with your Apple ID (Find My iPhone must already be configured on the missing device).

You’ll see your device’s location on a map and you can choose to have it display a message or play a sound, remotely lock the device, or wipe it to permanently delete all of your data if you think that it won’t be returned. For added security, the app will automatically sign you out after 15 minutes, or you can manually sign out at any time.

FEATURES
• Locate your iPhone, iPad, iPod touch on a map
• Send a message and optionally play a sound for two minutes at full volume (even if your device is set to silent)
• Remotely set a passcode lock on your device, or lock it using your existing passcode
• Remotely wipe your device to permanently erase all of your personal data

Please note that you must first set up and turn on Find My iPhone on each device you want to locate (installing this app is not required).

Supported languages: English, Japanese, French, German, Dutch, Italian, Spanish, Portuguese, Danish, Finnish, Norwegian, Swedish, Korean, Chinese, Russian, Polish, Turkish, Ukrainian, Arabic, Croatian , Czech, Greek, Hebrew, Romanian, Slovak, Thai, Indonesian, Malay, Catalan, Hungarian, Vietnamese

REQUIREMENTS:
This app requires iOS 3.1.3 or later.

To create a free Find My iPhone account, you need an iPhone 4, iPad, or iPod touch (4th generation) running iOS 4.2 or later. You can then set up your account on any device running iOS 4.2 or later.

Apple App Store

, , , , ,

Comments are closed.